eSign Outage

Incident Report for Storable Edge

Resolved

This issue has been resolved and we've determined that there was no tenant impact during the outage.
Posted Apr 24, 2025 - 12:28 EDT

Monitoring

Edge experienced a recent eSign outage. While the outage is resolved, our teams are investigating any impacted documents. We will provide updates and, if necessary, provide further instructions. Thank you for your patience as we monitor this issue.
Posted Apr 24, 2025 - 10:02 EDT
This incident affected: Storable Edge Software, Storable Edge Corporate, and Storable Edge Reporting.