The Storable Edge reporting discrepancy has been resolved. Thanks for your patience as our team resolved this issue.
Posted Jul 16, 2026 - 09:45 EDT
Monitoring
We have successfully implemented a fix. Storable Edge daily reports for July 8, 2026, have now been processed for almost all time zones. Reports for Alaska and Hawaii are currently in progress. Thanks for your patience. We will provide updates once this issue is resolved.
Posted Jul 16, 2026 - 08:57 EDT
Investigating
We have identified missing data affecting Storable Edge reports for July 8, 2026. Our engineering team is actively working to restore the missing metrics to ensure your reports are accurate. We estimate a full resolution by the end of US business hours today.
We apologize for the inconvenience and will provide updates as they become available.
Posted Jul 15, 2026 - 13:50 EDT
This incident affected: Storable Edge Software and Storable Edge Reporting.