Reporting issue

Incident Report for Storable Edge

Resolved

This issue has been resolved.
Posted Jun 13, 2025 - 14:01 EDT

Update

We've learned that a vendor outage caused the reporting issue. While some reports are inaccessible, you can still access these reports: Aging, Rent Roll, Delinquency Stages, Consolidated Occupancy, and Management Summary. We appreciate your patience and will provide updates as we learn more.
Posted Jun 13, 2025 - 12:44 EDT

Investigating

We're aware of an issue impacting reports in Edge. While we work to resolve it, we appreciate your patience and will provide updates as we learn more.
Posted Jun 13, 2025 - 12:18 EDT
This incident affected: Storable Edge Reporting.