Walkthrough Report Unavailable for Some Accounts

Incident Report for Storable Edge

Identified

We’ve made progress in resolving the issue affecting the Walkthrough Report. Our team has identified the cause in certain scenarios and is actively testing a complete solution. We appreciate your continued patience and will share further updates as they become available.
Posted May 08, 2025 - 14:57 EDT

Update

We are continuing to investigate this issue. We apologize for the inconvenience and appreciate your patience.
Posted May 07, 2025 - 10:51 EDT

Investigating

We are continuing to investigate this issue. We apologize for the inconvenience and appreciate your patience.
Posted May 06, 2025 - 11:14 EDT

Identified

We’re currently investigating an issue affecting some accounts where the Walkthrough Report fails to load and displays a blank page. Our team is actively working to resolve the issue. We’ll share updates as they become available. We apologize for the inconvenience and appreciate your patience.
Posted May 05, 2025 - 14:43 EDT
This incident affects: Storable Edge Reporting.