Tenants unable to complete online move-ins
Incident Report for storEDGE
Resolved
This issue has been resolved.
Posted Jun 26, 2024 - 11:43 EDT
Monitoring
A fix has been implemented and we're monitoring results.
Posted Jun 25, 2024 - 14:12 EDT
Identified
We've identified the issue and our team is actively working on a hotfix to resolve this as soon as possible. Thank you for your patience.
Posted Jun 25, 2024 - 12:57 EDT
Investigating
We are currently investigating an issue that is preventing tenants from completing online move-ins. We are working to resolve this issue as quickly as possible and apologize for any inconvenience this may cause.
Posted Jun 25, 2024 - 11:58 EDT
This incident affected: storEDGE Websites.