Close of Day disruption

Incident Report for Storable Edge

Resolved

This issue has been resolved.
Posted Jun 24, 2025 - 18:19 EDT

Monitoring

Our team has implemented a fix for the issue that was impacting the Close of Day process. We are actively monitoring system performance to ensure full stability. Thank you for your patience as we worked to resolve the issue.
Posted Jun 24, 2025 - 17:54 EDT

Identified

The issue has been identified, and a fix is in progress. We’ll provide another update soon.
Posted Jun 24, 2025 - 17:42 EDT

Investigating

We've identified the issue affecting Close of Day and are actively working on a fix. We'll provide another update as soon as we have more details or when the fix is implemented. Thank you for your patience.
Posted Jun 24, 2025 - 17:23 EDT
This incident affected: Storable Edge Software.