This issue has been resolved. Thank you for your patience.
Posted May 07, 2025 - 13:07 EDT
Monitoring
A fix has been successfully implemented, and we are currently monitoring the system to ensure stability and full recovery. We will continue to observe performance closely and provide further updates if necessary. Thank you for your continued patience and understanding.
Posted May 07, 2025 - 11:56 EDT
Update
We are continuing to investigate this issue.
Posted May 07, 2025 - 11:08 EDT
Investigating
We are actively investigating an issue that prevents Edge from loading for users. Affected users may experience the application attempting to load indefinitely without success. The Edge API is also affected. Our team is working urgently to implement a fix and updates will be provided when available. Thank you for your patience.
Posted May 07, 2025 - 11:05 EDT
This incident affected: Storable Edge Software, Storable Edge Corporate, Storable Edge API (Third-party integrations), and Rental Center.