Reporting issue

Incident Report for Storable Edge

Resolved

This issue is fully resolved, and all systems are operational. Thank you for your patience while we worked through this.
Posted Mar 02, 2026 - 14:49 EST

Monitoring

A fix has been implemented, and we are monitoring system performance. We’ll continue to observe the issue and post further updates if necessary.
Posted Mar 02, 2026 - 14:02 EST

Identified

We have identified a technical issue that may impact reporting for some users. This issue is causing intermittent failures in corporate PDF and email exports, as well as processing delays for certain trailing-day reports. Our team is actively working on a fix, and current signs from our ongoing infrastructure adjustments indicate a favorable resolution before March 1st.

To continue accessing your required report data while system stabilization efforts are underway, you can:

- Export reports at the individual facility level, which have shown higher success rates.
- Run the export for each facility separately rather than exporting your entire portfolio at once. This should allow you to access the documents you need while we finalize the broader fix.
Posted Feb 27, 2026 - 14:21 EST

Update

We are investigating a technical issue that may impact reporting for some users. This issue is causing intermittent failures for corporate PDF and email exports, alongside processing delays for certain trailing-day reports. Our team is actively working on a fix and will provide updates as they become available.
Posted Feb 26, 2026 - 15:21 EST

Investigating

We're aware of an issue impacting reporting. This issue causes corporate exports to PDF and email to fail, and delays with trailing-day reports. Our team is actively investigating the root cause. We appreciate your patience and will provide updates as we learn more.
Posted Feb 26, 2026 - 15:11 EST
This incident affected: Storable Edge Software, Storable Edge Corporate, and Storable Edge Reporting.